Menu

Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Show posts Menu

Messages - Commander Fluffypants

#1
Will!! You nailed it! There was a wire dangling off of one of the speakers. I couldn't see it until I took the *whateveryoucallitthatthespeakersaremountedto* off.

So simple.

Thank you again.

See you next time something breaks!
#2
So, it seems I'm still having problems with this thing. The folks at Vintage Vibe have been super helpful, but I don't want to drive them crazy... so I'm going to drive the nice folks here crazy for a while instead... so thanks in advance.

The Vintage Vibe guy said to send in my amp, but that thing weighs a ton. I recently sent a piece of rack gear to get repaired and it cost $80 one way (with insurance) and this weighs at least 10 times what that piece of rack gear weighs.

So here's my issue, and what I've ruled out:

One channel, Channel A, is dead. I swapped the speaker cables, swapped the speaker fuses, and even swapped the amplifier pcbs. In all situations, the same speakers get sound and the same speakers remain silent. That kind of rules out a lot of things. There's not much left. And seeing as that channel is dead silent, not intermittent or noisy, that also is useful information. If I try to plug an instrument directly into Channel A, nothing. Channel B works. I think that tells me it's not the 5 pin cable.

So...what's left? I know the headphone jack is somehow a switching jack. I used to plug headphones into it when I'd DI the piano and didn't want the speakers making sound. Would a malfunctioning headphone jack allow one channel to work while totally killing the other channel? Visual inspection tells me nothing.

I do not fear my soldering iron, but honestly I'm not an electronics person. All my electronics work has been "paint by numbers" style kits. That said, I have a meter and I'm not a complete idiot... but I am a drummer...

Anyone have any ideas on what it might be or can anyone describe what and how to check some things?

Thanks!!
#3
It works!!

So easy!

It only took a few minutes to open the amp up and swap the pcb. If anyone is doing a search and has a similar issue with their suitcase, get the preamp pcb from Vintage Vibe and swap it out.

Thanks again, Will, and thanks to the folks at Vintage Vibe and thanks to the Electric Piano Forum for being here when I needed it!
#4
Update on my situation. I decided to try to contact the folks at Vintage Vibe again. I got a response this time. I was reluctant to push it because I figure businesses like that must get too many requests for help without renumeration, and I totally wouldn't blame them (or any similar company) for just not responding. They asked me a couple of follow up questions, and to the best of their ability (not being able to inspect it themselves and all) they recommended I buy a new pre amp power supply pcb from them. This is kind of awesome because it's really plug and play. Kind of genius on their part. All I need to do is swap out the entire pcb. I don't *think* there's even any soldering involved. Just two cables that get plugged onto the pcb. Should be quick and easy. Under $50 including shipping.

Will, all of your help was also very... helpful. I was able to have an idea of what I was dealing with when I was talking with the Vintage Vibe people.

I will report back after I get the part and do the work
#6
Awesome! Those pics are going to be helpful.
#7
Thank you, Will.

I have determined that this piano is from 1979. I believe it is also the Janus preamp. It is exactly as pictured and described at the bottom of this page:

https://www.fenderrhodes.com/pianos/mark1b.html

Next step for me would be to visually inspect the amp, look for burnt components, and identify caps for replacement. If I understand your other threads, those caps would just be the canister style caps, correct?
#8
Thanks Bill!

The little I know about electronics made me think it might be caps. Thank you for the link. I'm going to read it and then if it seems it IS caps, I'm going to figure out where they are, what they are and swap those suckers out! I will report back. I'm sure I'll have more questions. I appreciate that there are more informed folks willing to share their knowledge and experience!
#9
Hi Electric Piano Forum Members,

I have a question that I'm hoping someone might be able to answer. I have a suitcase Rhodes (not mine) that lives at my studio, and due to Covid, it hasn't seen much action the past couple of years. I plugged it in a couple of days ago and it exhibited the following symptoms:

It powered up fine. The red indicator lamp next to the volume knob, however, almost instantly dimmed, as did the volume. (It lasted maybe two seconds.) Power stays on, but there's no real volume and that lamp is definitely dim. If I unplug the 5 pin connector and plug it back in, the result is the same as powering it off and on from the power switch.

I was still able to go out one of the accessory lines to another amplifier for that session, but I'd like to get the thing working properly again.

Does anyone recognize these symptoms?

I made a video of it. Link:  https://youtu.be/bR5jWJk8lFo

Thank you very much!

#10
Excellent! I have the fader preamp. Easy solution. Thank you so much!
#11
Hi folks,

I've done some searches on this site and others and this thread is one of a few that come close to my question, so I figured I'd try here first.

What I'm looking for is similar to a kill switch for the speakers. What I'm thinking is that a power amp kill switch is probably what I want. Perhaps there is already a way to do this and no mod is necessary. I have a humble project studio and for overdubbing the Rhodes by itself I will surely see what kind of results I get from miking the speakers. However, when tracking a live band in one room, I'd like to be able to use the preamp outputs without having the speakers on.

Would it be possible to wire in a switch that turns the power amp off, leaving the preamp on to get a DI signal? Even better, replacing the two position power switch with a three position switch...? And are there any concerns with damaging the preamp by having its signal only go to the preamp outputs?

I see that I can buy... or possibly used to be able to buy... an expensive preamp box that might do the trick, but these parts are already in the Rhodes! Or am I missing something?

Thanks!