Author Topic: "Cracking" sound on almost every key  (Read 3349 times)

Offline Goran

  • Fiesta Red
  • **
  • Posts: 10
    • View Profile
"Cracking" sound on almost every key
« on: January 07, 2006, 05:28:33 PM »
My chain is as following: Rhodes MKI 73-->tube preamp--->soundcard. When I turn on BBE Sonic Maximizer plug in (or whatever type of EQ) and boost high frequencies (to get that bell sound)I hear some kind of cracking sound when I hit almost every key, especially in low register.
  I must note that I have ground promlems in my house. If this means anything to you, when I plug in old Jazz Bass into preamp it has that clicking sound when I am touching the strings. On stage when ground is ok I don't have that problems.
  Does ground problem have anything with my cracking sound problem on Rhodes?

Thanks!

Goran

Offline Ben Bove

  • Vendor
  • MIDI Mark V
  • *****
  • Posts: 3280
  • Formerly bjammerz
    • View Profile
    • Retro Rentals Website
"Cracking" sound on almost every key
« Reply #1 on: January 07, 2006, 11:32:49 PM »
not sure if i'm following you, you have the rhodes connected line-in into your computer to record it from the pre-amp?  If you're using a PC or something check to make sure your line-in level isn't too high... is it like a distorted sound?
Retro Rentals
Vintage Music Gear

http://www.RetroRentals.net
(818) 806-9606
info@retrorentals.net

FB: https://www.facebook.com/retrorentals.net/
IG: @RetroRentalsNet

Offline Goran

  • Fiesta Red
  • **
  • Posts: 10
    • View Profile
"Cracking" sound on almost every key
« Reply #2 on: January 08, 2006, 05:16:35 AM »
All levels are ok, both in preamp and in soundcard. I checked everything what might be a reason to this but I can't move my Rhodes to studio where I work (and where are no ground problems), it's far away from my house and I don't have a car.
  Also don't know how to get that "belly" sound without boosting a quite amount of noise and that unpleasing sound that I mention above.

Offline jeffwuollet

  • Sparkletop
  • ***
  • Posts: 90
    • View Profile
"Cracking" sound on almost every key
« Reply #3 on: January 09, 2006, 05:19:04 PM »
Inside your rhodes, there is an RCA jack. Grab a Male RCA to Male 1/4" cable and plug that into your preamp. That will do two things, diagnose if the crackling is coming from the pots, jack or cabling; and also bypass a tone pot and volume control. Bypassing right from the RCA jack yeilds more highs than running through the controls on your rhodes. You might not need to EQ your Rhodes if you run it from the RCA's. If you still get a clicking, it might be bad solder leads in your rhodes. I had that problem on my '71. Just double check them.
If you want to know where to find the booze, ask the engineer...

Offline Goran

  • Fiesta Red
  • **
  • Posts: 10
    • View Profile
"Cracking" sound on almost every key
« Reply #4 on: January 12, 2006, 12:26:06 PM »
Your message was very helpful to me. When I connected RCA cable inside  I realized that screws on couple of pickups weren't tighten and pickups vibrated and made that noise. Yes, it sounds brighter but it might be unpleasant in certain moments.

Thank you very much!

Goran