Author Topic: Bass boost on Rhodes not working  (Read 271 times)

Offline JordanShadle

  • Pre-Piano
  • *
  • Posts: 6
    • View Profile
Bass boost on Rhodes not working
« on: March 01, 2019, 12:49:42 AM »
The bass boost knob doesn't do anything and I popped the cover to see some wires taped together as if a previous owner had tried to mess with it in some way. I have no idea what I'm looking at so can anybody out there check it out and maybe point to where I can find out how to fix it? https://imgur.com/a/1hGYEHP

Offline Tim Hodges

  • Vendor
  • Mark II
  • *****
  • Posts: 803
  • Tim
    • View Profile
    • Facebook
Re: Bass boost on Rhodes not working
« Reply #1 on: March 01, 2019, 07:03:23 AM »
Definitely looks a bit funny, any chance you can remove the namerail to provide a photo from behind?
Bristol Electric Piano
UK

Facebook
YouTube
Reverb.com

Offline JordanShadle

  • Pre-Piano
  • *
  • Posts: 6
    • View Profile
Re: Bass boost on Rhodes not working
« Reply #2 on: March 01, 2019, 08:53:39 PM »
I tried to pull back the taped wires to show which ones were connected to each other. Hopefully you can see what's going on from this, if not just let me know and I can try again haha https://imgur.com/a/G6yMUUD

Offline sookwinder

  • Fiesta Red
  • **
  • Posts: 47
    • View Profile
Re: Bass boost on Rhodes not working
« Reply #3 on: March 02, 2019, 04:37:01 AM »
BTW, not withstanding what Fender/Rhodes called it, it isn't actually a bass boost ... it is a bass cut.
Just the same principle as the bass control on an amp... a high pass filter.
One extreme allows all the signal through, the other extreme cut the bass signal.
Late 60s Pianet N - Late 70s Pianet T - Ensoniq ESQ1 - Hammond XK2 - Wurli 206A converted to a 200A - 1973 Rhodes Stage 73 - Roland RD150 - Vintage Vibe 64 EP - s**t load of guitars, basses & amps

Offline JordanShadle

  • Pre-Piano
  • *
  • Posts: 6
    • View Profile
Re: Bass boost on Rhodes not working
« Reply #4 on: March 02, 2019, 09:21:00 AM »
Good to know! I hope to hear it first hand sometime soon lol

Offline pnoboy

  • Mark I
  • ****
  • Posts: 392
    • View Profile
Re: Bass boost on Rhodes not working
« Reply #5 on: March 02, 2019, 02:43:38 PM »
The schematic for what should be in your stage schematic is super simple.  You can find a diagram here http://www.fenderrhodes.com/img/service/manual/stgschem.gif.  For more sparkle in the sound, I recommend scaling the values.   For example, you could use a 50k pot for the volume control, a 250k pot for the bass control and a 10nF capacitor.  To raise the impedance even more, you could use a 100k volume pot, a 500k bass pot, and a 4.7 nF capacitor.

Offline sean

  • Mark II
  • *****
  • Posts: 792
    • View Profile
Re: Bass boost on Rhodes not working
« Reply #6 on: March 03, 2019, 09:09:04 PM »

Compare your circuitry to the diagrams and photos at https://ep-forum.com/smf/index.php?topic=4650.msg22605#msg22605

Sean

Offline JordanShadle

  • Pre-Piano
  • *
  • Posts: 6
    • View Profile
Re: Bass boost on Rhodes not working
« Reply #7 on: March 03, 2019, 11:55:48 PM »
I was having trouble figuring out the schematic but that wiring diagram helps me out a lot. Thank you very much!