Author Topic: Baldwin Piano Pro EP101 - Very loud sounds  (Read 226 times)

Offline Lopazopy

  • Pre-Piano
  • *
  • Posts: 2
    • View Profile
Baldwin Piano Pro EP101 - Very loud sounds
« on: March 27, 2019, 07:35:02 PM »
I recently picked up this piano in non-working condition to see if I could get it going. Unfortunately, there is absolutely no information on the web about this model to help me troubleshoot. To remedy some of that, I'm going to post some info and pictures so at least there is something out there for anyone else looking for information. Also, if you could help me towards fixing my problem, I'd greatly appreciate it.

The Info
This model is all electric with no strings, pickups, reeds, or tines. This is what the front looks like (which can be found elsewhere on the net).


A closer look of the control buttons, volume and tempo dials, lcd, etc.


Nameplate. I can't even find info about serial numbers to try and date the piano. If anyone has any ideas about the date code before the serial number (F 48 B), I'd love to hear it.


Now, here are some pictures that I couldn't find on the net. A look at the guts. I can get to most stuff except the input boards for the keys. That would require more disassembly. Here is a look at the lower right corner that shows the power boards, transformer, and amp board.


Next up, we have the pedals.


And on the far left we have the black box that houses the sound boards.


Here is a peak inside the black box that shows the sound boards.


If you would like more pictures or info, let me know and I'll see what I can get.

The Problem
When the piano is turned on, very loud sounds come out of the speaker. Same thing happens through the headphone jack. This isn't some ground loop hum. The best way I can describe it is all the notes are played at the same time as loud as possible. And the volume knob is turned all the way down and does nothing. Here is a video of what the piano is doing.

https://youtu.be/tygryMXNL4s

Luckily, I was able to find another post on the forum that told how to turn the volume down using a pot trimmer on one of the sound boards.

Troubleshooting
I can unhook the signal wire coming from the sound boards and going to the amp and that stops the noise. Of course that stops all noise. This leads me to believe I have a problem in the sound boards somewhere. Hopefully I'm wrong because there are 13 soundboards to try and find a problem. All the electronics look fine. No swollen caps, no burnt traces, nothing leaking, etc.

Is there a way to feed a signal to the amp to verify there isn't a problem with the amp?

Any ideas of what I can look at and test with a multimeter?

Thanks in advance for any help!
« Last Edit: March 27, 2019, 07:37:24 PM by Lopazopy »

Offline vanceinatlance

  • Mark I
  • ****
  • Posts: 219
    • View Profile
Re: Baldwin Piano Pro EP101 - Very loud sounds
« Reply #1 on: March 28, 2019, 11:18:23 PM »
Interesting to see pics of the insides of this model. I always wondered if this model had strings or not, now I know. Unfortunately, there is no easy answer for fixing something like this. I feel pretty safe to say that you should replace the large filter caps on the power supply, simply because if it's age. They can appear ok, but still be way out of tolerance. Dirty power can cause odd behavior such as what your video seems to represent. The filter caps alone may cost you more than the piano may be worth though. That is where I would start the jurney if it were me. Thanks for sharing the pics and info and hope you find an easy fix for it.

Offline Lopazopy

  • Pre-Piano
  • *
  • Posts: 2
    • View Profile
Re: Baldwin Piano Pro EP101 - Very loud sounds
« Reply #2 on: April 04, 2019, 09:23:17 PM »
Interesting to see pics of the insides of this model. I always wondered if this model had strings or not, now I know. Unfortunately, there is no easy answer for fixing something like this. I feel pretty safe to say that you should replace the large filter caps on the power supply, simply because if it's age. They can appear ok, but still be way out of tolerance. Dirty power can cause odd behavior such as what your video seems to represent. The filter caps alone may cost you more than the piano may be worth though. That is where I would start the jurney if it were me. Thanks for sharing the pics and info and hope you find an easy fix for it.

UPDATE

Thanks for pointing out the filter caps. I had read about them before, but dismissed them since they looked fine visually. I didn't have a good way to test the capacitors, so I just decided to replace the 6 big ones. The large blue can seen in the pics in my previous post was a 3 section capacitor, and I replaced it with 3 individual capacitors. The cost for replacing all 6 caps was $15.92 shipped from Digi-key. Not too bad.



Sadly, this didn't fix the problem. :'( No change of symptoms, which has me feeling a little discouraged to continue troubleshooting. I did disassemble it a little more to get a good look at the keys. From what I've read about the different type of contacts, this is a bus bar (busbar) system. There is a spring connected to the key and resting on a metal rod. When the key is pushed, the spring is lifted off the bottom metal rod and contacts the top metal rod. The piano claims to have velocity input, so I'm guessing it calculates the time it takes for the spring to be lifted off the bottom rod and make contact with the top rod to determine how loudly to play the note. Shorter time=faster key movement=pressed harder and vice versa. I also saw the back of the keys have weights and you can definitely tell from the clunk sound you hear when you lift off a key.



Ideas for the future of this piano? I'm suspecting something going on with the boards. I'll pull the boards out to see if I can do any troubleshooting there. Obvious bad parts, reseating chips, reseating the boards, cleaning connections, etc. I have been reading some about MIDI-fying old organs and such that has peaked my interest. If I can just use the key actions and cut out everything else and use it just for a MIDI keyboard, I'd be happy with that.

Offline vanceinatlance

  • Mark I
  • ****
  • Posts: 219
    • View Profile
Re: Baldwin Piano Pro EP101 - Very loud sounds
« Reply #3 on: April 05, 2019, 11:10:56 AM »
Sorry to hear that didn't fix the issue. If you continue to try and fix it,  I would verify that the power supply is now giving you the correct voltage output to the piano and with minimal ac ripple. Other things you can check are if liquid was spilled in the keyboard. Sometimes cola or other liquids can play with connectivity on traces or cause bad traces. Many many things can lead to odd issues and you can find yourself wasting time and money very fast. Have fun playing with it or run away fast if you are already not too deep into it. Hope it works out for the best.
Vance