Author Topic: Mark 2 difficulties  (Read 121 times)

Offline Coolestdudest

  • Pre-Piano
  • *
  • Posts: 1
    • View Profile
Mark 2 difficulties
« on: January 19, 2021, 10:09:42 AM »
Hi! I'm new to this website and all the information so please have patience with me! An old Rhodes Mark 2 happen to fall into my hands (for free too!) and I'm having difficulties getting it to work. I've searched all over the internet for information and I can't seem to find anything. Basically I can't get any sound to come out of my amp. I know that I found a lot of info on the suitcase amps that they were designed to work with or something like that and my amp is simply just a cheap modern amp but I don't know what to do. I also found a lot of info on wiring and the power supply dying but I'm certainly not an expert on any of that stuff. Thank you so much for your time! If you think it might just be a wiring issue, if you could reccomend some place or someone in the LA area who could help me out that'd be great. Thanks a bunch!

Offline sean

  • Mark II
  • *****
  • Posts: 926
    • View Profile
Re: Mark 2 difficulties
« Reply #1 on: January 19, 2021, 01:15:57 PM »
First, slow down, breathe... take a pause, relax.  (although not in all caps, you sound out of breath)
You have come to the right place.  If we can't help you, there are Rhodes techs in LA that will chime in.

I assume you have a seventy-three key Mark II stage piano.  Is this correct?  It looks like this:
or

The stage piano does not have a power supply or amplifier beneath it.  Just a piano top on four legs.  The Stage Piano will have only one 1/4" jack on the face panel... oh, I forgot the obvious... It will have the words "Stage Piano" on the name rail.  Ha.

[If your piano has a built-in preamp, then you have either a Rhodes Janus Piano (missing the amp), or you have a Suitcase model Rhodes (also missing the amplifier base).  These two model pianos require a power supply for the internal preamp.]

I will assume you have a STAGE PIANO.

In a perfect world, if you plug a guitar cable from the output of the Rhodes (deceptively marked "Input") to the input of your guitar amp, you will get music.  If you don't, there are a few things that could be wrong, but it is almost always this: some of the pickups in the piano are dead.  If there are three dead pickups in a row (a whole group-of-three is dead), you get no output from the Rhodes.

(There are other things that could be wrong too:  maybe the RCA jack is corroded, maybe the cable from the RCA jack is unplugged or defective, maybe the controls on the name rail are defective, or maybe the 1/4" jack is screwed up, or maybe a ground wire is broken, or ....)

The method of finding all the dead pickups is reasonably well-discussed here: 
           https://ep-forum.com/smf/index.php?topic=10307.msg57408#msg57408
           (This post has links to other similar posts at the bottom.)

Take a good look around inside your Rhodes, and send us some pictures if you can.

Of course, you should read the service manual a bunch of times:  https://www.fenderrhodes.com/service/manual.html
See also the technotes at:  https://www.fenderrhodes.com/service/technotes.html

Sean


By the way, I completely disagree with your assertion that you have search all over the internet.   :-)