Author Topic: Building my own preamp power supply. Not working so far.  (Read 14596 times)

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Building my own preamp power supply. Not working so far.
« on: December 10, 2010, 07:20:43 AM »
So, I have build my preamp power supply. I'm using MIDI DIN connectors instead of the 4 pin connectors. It powers up, so that's a good sign. Both light bulbs still work. But I cant get the right output out of it yet.
Its a very low volume, distorted sound I'm getting so far. I don't know if its the preamp or my power supply box outputs. I have everything hooked up correctly, all pins are going to the right pins. I'm not sure where the output jacks sleeve terminals should go, since there is no where for them on the pin connector. I tried just putting them to ground but its still giving me this distorted low volume output. Its bearly even an output at all.
Please help? What am I missing here?
Fender Rhodes 88 key - Suitcase Model

Offline Rob A

  • Global Moderator
  • Mark V
  • *****
  • Posts: 1386
  • Modal Globerator
    • View Profile
    • Rhodes buyer's guide
Re: Building my own preamp power supply. Not working so far.
« Reply #1 on: December 10, 2010, 08:01:56 AM »
Have you measured the voltage output of your supply under load? Did you use a voltage regulator?

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #2 on: December 10, 2010, 03:01:52 PM »
No I haven't. I'm using a 24V DC power supply. Its enough to turn it on at least.
The layout is very simple. the +V goes right to the 25V pin, and the ground goes to the ground pin, while the audio outputs go to the other two pins. There's nothing in between them. Does there need to be?
Fender Rhodes 88 key - Suitcase Model

Offline Rob A

  • Global Moderator
  • Mark V
  • *****
  • Posts: 1386
  • Modal Globerator
    • View Profile
    • Rhodes buyer's guide
Re: Building my own preamp power supply. Not working so far.
« Reply #3 on: December 10, 2010, 04:02:33 PM »
I'm not sure I understand your last question. Audio signals need to be referenced to a ground connection.

I was posting before based on a hunch that the load may be causing your supply voltage to sag well below 24V. So the point of the meter check on supply voltage, which should take a quick second, is to rule that out.

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #4 on: December 11, 2010, 12:40:10 AM »
Ok, I messured the voltage going into the preamp. Its only 23 volts...darn.

What do I need to do to get it the 25 volts it needs? Does this mean I would need a 26V power supply or something?
Fender Rhodes 88 key - Suitcase Model

Offline Rob A

  • Global Moderator
  • Mark V
  • *****
  • Posts: 1386
  • Modal Globerator
    • View Profile
    • Rhodes buyer's guide
Re: Building my own preamp power supply. Not working so far.
« Reply #5 on: December 11, 2010, 09:10:26 AM »
Well, that's not obviously the problem. Most power supplies have a certain amount of tolerance, say +/- 10% would not be unusual. If you were getting 18V I'd say that's the problem. 23 is close to the goal. You probably also have to use your 200V range on the meter, so that's also contributing a little to the uncertainty.

I'm just wondering if the supply is being loaded (current) to perform well outside of its design specs. It seems not to be, so let's go after your audio connections. Are they referenced to the same ground as the power supply? Put another way, is the audio ground connected to power ground?

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #6 on: December 11, 2010, 10:24:10 PM »
oh thats great. ill keep that in mind next time :)

yes, they are. i dont know where else they would go seeing how theres only one ground pin. im pretty sure i have them connected right, they both go to the preamps dual outputs.

EDIT: I just tried the output right from the preamp board itself and its doing the same thing, so its not the cable or the audio jacks on the power supply unit. I have no idea whats wrong, its giving some sort of output, but its so low and distorted. I hope its not a bad amp.
« Last Edit: December 12, 2010, 12:22:48 AM by Wavedude »
Fender Rhodes 88 key - Suitcase Model

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #7 on: December 12, 2010, 03:47:49 PM »
Ok, its gotta be something in the preamp. There's some bad components or something, because when I use my test leads to get audio along some of the circuit path, some components work and other aren't. Ive followed the path of the audio from the Rhodes and so far I've come across some transistors that might be bad, or some capacitors that might be bad as well. I need a schematic of the circuit so I know what the values are supposed to be when I check them, but I cant seem to find it yet. If anyone knows where I can find one, please help.
« Last Edit: December 12, 2010, 11:13:48 PM by Wavedude »
Fender Rhodes 88 key - Suitcase Model

Offline sean

  • Mark II
  • *****
  • Posts: 943
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #8 on: December 13, 2010, 08:58:03 AM »


You can still get the schematics from www.fenderrhodes.com, but the individual links to the figures in chapter 11 are broken right now.  James will eventually fix this, I hope.

Anyway, you can still download the zip file from http://www.fenderrhodes.com/service/manual.php

After you download the Amp Schematics zip file, use the old chapter eleven page to figure out which schematic you need.  The list of figures is still here:  http://www.fenderrhodes.com/org/manual/ch11.html

I believe that you need figure 11-8.   (and to a lesser extent, 11-9, 11-10, and 11-11)

===============

To make Rob's point painfully clear, make sure you are testing for audio output for:
     -  channel 1 on pins 2 (hot) and pin 4 (ground), and
     -  channel 2 on pins 3 (hot) and pin 4 (ground).

===============

You should check the power supply's ability to provide enough current.

As Rob said, I agree your power supply should be fine.  There is a small chance that your power supply can't provide enough current, but I doubt it.  I would be amused if your power supply has some tiny output rating (like 20mA), but it probably can push the 200mA or so to make the preamp function.



Sean





Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #9 on: December 13, 2010, 12:16:08 PM »
Oh thanks for the links for the schematics. It was bothering the heck out of me that they are all broken.

Ok, so, I know the problem isn't in the audio. It has to be the power supply, or bad components on the board.

Before I check the components, I just now realized I forgot about specifying the mA rating on the power supply. It's 24V DC 100mA output. I don't know if that's enough or not, I cant find the specs on what the original rated output on the power supply is. Please let me know if its not.
If it's fine, then I'll just have to move on to the components.
I checked all transistors, The vibrato and eq ones are fine. The ones in the amp section are questionable. What should I expect the values to be reading? If none of the transistors are bad, then that's good, it would just be a bad cap or something. But I would think its highly unlikely to be something other than one of those old transistors.

I'll keep checking them, but let me know if I'm getting the right current. I appreciate all your help, this is getting so stressful by myself, haha  ;)
Fender Rhodes 88 key - Suitcase Model

Offline Rob A

  • Global Moderator
  • Mark V
  • *****
  • Posts: 1386
  • Modal Globerator
    • View Profile
    • Rhodes buyer's guide
Re: Building my own preamp power supply. Not working so far.
« Reply #10 on: December 13, 2010, 03:22:05 PM »
Just remember that power supply ratings aren't really a promise to deliver. What that nameplate is telling you is that if you load the thing at around 100mA, you are going to be reasonably (in some cases not very reasonably) assured of getting a 24V output voltage, plus or minus some reasonable tolerance.

You could meter the current draw. I went looking for any clues about how much the preamp wants, but I came up empty.

I think changing .org to .com in the schematics links makes them work, but I'm not where I can easily check right now.

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #11 on: December 13, 2010, 04:02:15 PM »
The draw reads to be 193 mA going into the preamp, that sounds ok, right? I downloaded the schematics and they don't tell me how much current it needs. I did find out that the voltage regulator took in 35V and condensed it to 25 though, but I'm not sure if that's what I'm needing, since I'm not powering a speaker cabinet or other auxiliary amp.

By the looks of all the info we have so far, it seems like the power supply is fine. Moving onto the components, All transistors are fine. I'm not sure if I'm checking the caps right with my multimeter.
Fender Rhodes 88 key - Suitcase Model

Offline BJT3

  • Mark I
  • ****
  • Posts: 378
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #12 on: December 13, 2010, 09:56:20 PM »
Not sure if this is your problem, but I built a power supply for mine and I'd have to go back and check the exact voltages but I remember it needing plus and minus voltage, so a standard plus only power supply (in reference to ground) probably won't work.
1978 Mark I Stage Piano 88
1970 Wurlitzer 200
Hohner D6 Clavinet
1961 Hammond A100 Organ
1977 Fender Twin Reverb (Blackfaced)

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #13 on: December 14, 2010, 11:37:24 AM »
The problem is the power adapter. Its not enough current. Its only 100 mA when it needs to be like a whole amp or so. I'm gonna try to find a power adapter that will provide that higher current.

Thanks for putting up with me everyone, you've been great help :)
Fender Rhodes 88 key - Suitcase Model

Offline sean

  • Mark II
  • *****
  • Posts: 943
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #14 on: December 14, 2010, 12:00:59 PM »

There were a few different preamps, with two major power supply configs.

The four-pin preamps need a power supply with only +25VDC.  
(80-watt Peterson, four-pin connector (early square, later round), FR-7054 Amp.  Production ending in 1977.)

The five-pin preamps need a power supply with +15VDC and -15VDC.
(100-watt Hagler, five-pin XLR connector, FR-7710 Amp.  Production starting in 1977.)

(Before 1969 they had the Jordan preamp that got +24VDC power via the ring of a tip-ring-sleeve 1/4" jack.)

=========================

You said you had a power supply rated at 100mA, but you also say you measured the current at 193mA.  That is a big problem!  That is way outside the design rating for the power supply.  Put your finger on the transformer and take it's temperature.  Warm is expected, hot is not good.

Your power supply is pushing all the little electrons it can, but the circuit isn't performing.  

I think your power supply is a major part (if not the only part) of the problem.



Oh, BTW, Rob is right, the links to the chapter 11 diagrams will load correctly if you change the ".org" to ".com".

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #15 on: December 14, 2010, 03:29:26 PM »

I think your power supply is a major part (if not the only part) of the problem.


Oh crap, and I just got a bigger power supply too. I was told its not enough current, and I needed something with more amps, so I got a 30V DC with 1000mA, lol...bad idea?

Its still not working either :p
Fender Rhodes 88 key - Suitcase Model

Offline sean

  • Mark II
  • *****
  • Posts: 943
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #16 on: December 14, 2010, 04:17:47 PM »


That sucks.  Bad luck.  But I think you did the right thing.

At least now you can test with confidence that it is NOT a power supply problem.

Maybe running the preamp at 25% over-voltage is not the best idea (especially for geriatric capacitors), but it probably isn't catastrophic.  However, there are a lot of caps that are only rated for 25V, and they are old and feeble.   Replace the electrolytic caps with new ones rated for higher voltage, like 50V.

You should probably replace all the electrolytic caps (because it isn't all that hard to do), and suspect that a transistor stage has been fried.

Don't get discouraged.  When you finally get through this hassle, you will be plenty happy.

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #17 on: December 14, 2010, 09:28:23 PM »
What should the transistors be reading? I've tried metering them and they all read something, but what should be the ideal reading?

I also don't have a capacitor reader on my meter either, so how can I check the caps?

I'm still learning how to read this thing, I just got it, lol. Best thing I've gotten for circuitry to date.
Fender Rhodes 88 key - Suitcase Model

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #18 on: December 15, 2010, 05:47:14 PM »
Ugh, this is a pain. That over-priced vintage vibe power supply is laughing in my face right now.

Ok, new update: I replaced some capacitors that were definitely bad. All the Red with yellow and black striped ones were falling apart in my hands. So the caps should be better now.
But the power input is still wrong. I took back that 30V transformer I got, and tried out the 24V one again, and of course it was the same problem, no audio output.

I think its time to take the power situation into my own hands. I'm building my own voltage regulator. According to the specs I've gotten so far, I need 25 volts with 3.2 amps of current draw. The closest thing I've seen for sale is 25.2V 2.0A. I don't know if that's going to be enough amps, but it doesn't seem like I have any other choices. Is this ok?
Fender Rhodes 88 key - Suitcase Model

Offline Rob A

  • Global Moderator
  • Mark V
  • *****
  • Posts: 1386
  • Modal Globerator
    • View Profile
    • Rhodes buyer's guide
Re: Building my own preamp power supply. Not working so far.
« Reply #19 on: December 15, 2010, 06:56:02 PM »
If this was my project, I'd look at an LM317T adjustable voltage regulator IC. It will need two external resistors that set the voltage to 25V.

Vout = 1.25V * ( 1 + R2/R1 )

So 180 ohms and 3.3k ohms are in your ballpark there.

You'll also need to arrange an input voltage that's over 27V. You will need a heatsink too.


« Last Edit: December 15, 2010, 07:19:05 PM by Rob A »

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #20 on: December 15, 2010, 08:04:08 PM »

You'll also need to arrange an input voltage that's over 27V. You will need a heatsink too.


But where am I going to find a transformer that goes that high? The highest I've found is 25.2.
Fender Rhodes 88 key - Suitcase Model

Offline BJT3

  • Mark I
  • ****
  • Posts: 378
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #21 on: December 16, 2010, 11:54:12 PM »
3 amps? What is it powering? My Twin Reverb has a 2 amp fuse I think.
1978 Mark I Stage Piano 88
1970 Wurlitzer 200
Hohner D6 Clavinet
1961 Hammond A100 Organ
1977 Fender Twin Reverb (Blackfaced)

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #22 on: December 17, 2010, 03:14:57 AM »
3 amps? What is it powering? My Twin Reverb has a 2 amp fuse I think.

It's powering the preamp itself. It's an 80 watt machine, needing 25 volts of power. So do the math (I=W/E), the current calculates to 3.2 amperes.
Fender Rhodes 88 key - Suitcase Model

Offline sean

  • Mark II
  • *****
  • Posts: 943
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #23 on: December 17, 2010, 09:38:52 AM »

You don't have to provide 80 Watts of power to the preamp.

The only data I have found is jens stating that 250mA is enough http://ep-forum.com/smf/index.php?topic=73.0 and another post saying that 500mA is definitely plenty.

(The power amp was fed by a different power supply section:  the unregulated +/- 35V connections to the AMP connectors shown on http://www.fenderrhodes.com/ch11/fig11-10.jpg)


Go get your 30Volt transformer back.

Build yourself a power supply something like:

(Stolen from http://blog.hackerspace.my/diy-0-30v-regulated-power-supply.)

There is plenty advice online about how to test transistors with your multimeter.  A good search engine will help you find it.

Sean


Offline Rob A

  • Global Moderator
  • Mark V
  • *****
  • Posts: 1386
  • Modal Globerator
    • View Profile
    • Rhodes buyer's guide
Re: Building my own preamp power supply. Not working so far.
« Reply #24 on: December 17, 2010, 10:12:54 AM »
sean got in before me, but I agree--the 80W spec is actually describing the power amp output rating, nothing at all about the preamp.

500mA @ 25V is 13W, which is a LOT of power for a preamp (you'd expect heatsinks to dissipate that 13W somewhere). I think that's extremely conservative ratings-wise, but I have not found info that would allow calculating the real requirement.

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #25 on: December 17, 2010, 12:37:12 PM »
Thanks a bunch, that's been the most help so far.

Will this transformer be ok? It comes close to the specs: http://www.mouser.com/ProductDetail/Tamura/SB2816-1630/?qs=sGAEpiMZZMv4oUrzpPKU3CFLRivkIP8cb1UkiVHaKRI%3d

I don't know how I missed that power supply tutorial in my searches. Thanks so much for bringing it up.

EDIT: After thinking a bit, that pot they want you to use for controlling the voltage output seems a little unnecessary. Can I leave that out somehow?
« Last Edit: December 17, 2010, 12:44:27 PM by Wavedude »
Fender Rhodes 88 key - Suitcase Model

Offline sean

  • Mark II
  • *****
  • Posts: 943
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #26 on: December 17, 2010, 12:57:11 PM »

No man.  That transformer has pretty low current output.  You will be in the same boat as before.
Look at the spec sheet.  The units that are in the 26V or 30V when wired for the series connection cann only put out 60 or 55 mA.


What happened to that 30V transformer you had that was rated for 1000mA?  That would be ideal.


Mouser's little catalog search/filter tool makes it pretty easy to find what you need.
For instance, I think Mouser 546-229C30 would be fine.  30VAC at 800mA, it is small, 115/230VAC input.

Offline Wavedude

  • Sparkletop
  • ***
  • Posts: 56
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #27 on: December 17, 2010, 01:12:17 PM »
Oh ok, I must have read it wrong. It looked like the same specs as the one used in the tutorial.

If I can get a transformer cheaper on mouser, that would be a ton better. That one you suggested seems good. It really is hard to find things on there though. I was searching for something like that and it kept giving me no matches.
Fender Rhodes 88 key - Suitcase Model

Offline Rob A

  • Global Moderator
  • Mark V
  • *****
  • Posts: 1386
  • Modal Globerator
    • View Profile
    • Rhodes buyer's guide
Re: Building my own preamp power supply. Not working so far.
« Reply #28 on: December 17, 2010, 02:23:56 PM »
Let's separate a couple things here--

If you are shopping for a transformer (by which I mean AC in, AC out), then you will need additional components (full wave rectifier, filter caps) to get DC to drive the voltage regulator IC, and you'll need to handle some math to convert the required AC voltage at the secondary to rectified DC. AC voltages are measure in Volts RMS, so there's conversion necessary. You only get 90% of the transformer's secondary voltage available as DC rectifier output, minus 1.4V dropped across the rectifier diodes.

http://www.electronics-tutorials.ws/diode/diode_6.html

So to get your 27V DC input to the LM317 you'd need a transformer with secondary rated at (27+1.4)/0.9 = 32VAC or higher.

http://www.allelectronics.com/make-a-store/item/TX-36/36VCT-0.8A-TRANSFORMER/1.html

If you are talking about a "transformer" or "wall wart" with a DC output, then you can use the DC output as labeled on the nameplate as long as you are within the load current labeled on the wall wart.
« Last Edit: December 17, 2010, 02:25:41 PM by Rob A »

Offline sean

  • Mark II
  • *****
  • Posts: 943
    • View Profile
Re: Building my own preamp power supply. Not working so far.
« Reply #29 on: December 17, 2010, 03:18:50 PM »


Cool.  Thanks Rob.

Then go for the similar transformer at 34 Volts: Mouser 546-229C34 - 34VAC, 700mA output.