Author Topic: Low volume and hiss on my MK 1 Stage  (Read 516 times)

Offline Mister Bailey

  • Pre-Piano
  • *
  • Posts: 8
    • View Profile
Low volume and hiss on my MK 1 Stage
« on: July 15, 2017, 07:28:59 AM »
Hi,

I have a 1979 mk 1 73 stage Rhodes which I bought a few months ago. I've not owned one before so am not sure if this is to be expected but the output volume is low to the point that I have to turn the volume on my amp (a KC-110) to full.  There is also an annoying hiss when a note is played which dissappears as the note fades.  This is especially noticeable when I use my Small Stone Phaser which "pulses" the hiss.  I have tried connecting directly to the harp RCA jack but this does not improve the quality of the output.

Possibly unrelated, I have seen photos online where a "grounding" wire runs from the RCA to a screw in the metal of the damper rail.  I do not have this cable on my Rhodes and do not an obvious appropriate screw on the rail.  However, I've read that not all models have this wire.

Any recommendations on how I might fix the hiss and volume issues would be greatly appreciated.  :)  It is ruining my enjoyment of my Rhodes.  >:(
 

Offline sean

  • Mark I
  • ****
  • Posts: 696
    • View Profile
Re: Low volume and hiss on my MK 1 Stage
« Reply #1 on: July 15, 2017, 09:58:27 PM »


The Rhodes has much much lower output than any modern electronic keyboard.  The Rhodes output is similar to electric guitar output.

Channel 1 on the KC-110 has more gain than channel 2 and 3, so try plugging the Rhodes into channel 1.  But you quite likely will not get your Rhodes as loud as the other keyboards.

In this situation, you will probably be happy adding some gain with a little preamp.  An MXR Micro Amp. or similar, will work with your off-grid battery-powered lifestyle.  Lots of other effect pedals have a little bit of gain that might help.   With the amp gain set in their middle ranges instead of the top of their headroom limits, the hiss problem should go away.

On my 79 Mark I, there is no ground wire to from the harp to the damper bar.

Sean



Offline Ben Bove

  • Vendor
  • MIDI Mark V
  • *****
  • Posts: 3257
  • Formerly bjammerz
    • View Profile
    • Retro Rentals Website
Re: Low volume and hiss on my MK 1 Stage
« Reply #2 on: July 17, 2017, 01:57:31 PM »
Try channel 1 as Sean recommends, I'm not familiar with the KC-110 (I think I had a KC 350?).  But without a doubt, no 30W keyboard amplifier should have to be at full volume.  The hiss I'm sure is coming from the amp being at full volume.  Let us know if that changes anything.

If not, it would initially be checking out the RCA cable / jack contact, stage controls, and pickup wiring.  The sustain grounding wire eliminates a grounding buzz not a hiss, so the piano would sound like a fluorescent light.  This was only for pianos before late 1975 when they switched to aluminum action frames, and the metal grounds itself.
Retro Rentals
Vintage Music Gear

http://www.RetroRentals.net
(818) 806-9606
info@retrorentals.net

FB: https://www.facebook.com/retrorentals.net/
IG: @RetroRentalsNet

Offline Mister Bailey

  • Pre-Piano
  • *
  • Posts: 8
    • View Profile
Re: Low volume and hiss on my MK 1 Stage
« Reply #3 on: July 20, 2017, 09:18:00 AM »
Thanks Ben & Sean,

Using channel 1 on my amp has helped a little.

I think that I will investigate the pickup wiring.  Soldering looks a bit dodgy in places.


Offline David Aubke

  • Vendor
  • Mark V
  • *****
  • Posts: 1195
    • View Profile
    • Shadetree Keys
Re: Low volume and hiss on my MK 1 Stage
« Reply #4 on: July 21, 2017, 08:20:12 AM »
Rhodes do make a relatively weak signal but any standard guitar amplifier from a practice amp to a Marshall stack should be able to make a reasonable sound.

As suggested, check the RCA jack at the rear of the harp. The signal is ready to go directly into an amplifier from that point so if you have an RCA-to-1/4" adapter, you can test from there. The controls on the name rail are passive, the same as on an electric guitar. All they do is remove volume and/or treble. Some folks bypass them altogether and control volume and tone at the amplifier.

So, if you get a good signal from the RCA, you know your name rail controls are the problem. If not, you at least know where to start your investigation.. and the jack itself should probably be Suspect #1.
Dave Aubke
Shadetree Keys

Offline The Real MC

  • Mark I
  • ****
  • Posts: 738
    • View Profile
    • My '67 sparkletop Rhodes
Re: Low volume and hiss on my MK 1 Stage
« Reply #5 on: July 30, 2017, 10:58:28 PM »
Rhodes with no active preamp (stage pianos or direct off the RCA socket on the harp) are very sensitive to input impedances.  Not all keyboard or guitar amps work well with them and the wrong ones will load down the pickups enough to create noise and a low output.  If you have other amps, try them.

You may also have a defective RCA socket.  I have gigged since 1981 and have banned the damn things from my arsenal as they have proven to be unreliable.  I replaced the RCA socket on my Rhodes with a 1/4" socket.

Offline mrchibbs

  • Pre-Piano
  • *
  • Posts: 5
    • View Profile
Re: Low volume and hiss on my MK 1 Stage
« Reply #6 on: November 30, 2017, 11:06:50 PM »
I know this reply is delayed, but I've had the same issue on a 1973 piano, and installing a ground wire to the damper rail does NOT fix the issue.

In my case, going straight off the harp helped things a little, but it's still not perfect.
1971 Fender Rhodes Mark I Stage 73
1973 Fender Rhodes Mark I Stage 88

Offline Mister Bailey

  • Pre-Piano
  • *
  • Posts: 8
    • View Profile
Re: Low volume and hiss on my MK 1 Stage
« Reply #7 on: February 09, 2018, 04:04:57 PM »
Thanks Mr Chibbs,

It’s nice to have another “Mr” on the forum.   :)

I’ve not touched the Rhodes for a while (recently got a Moog synth which is getting all my attention :D) but I’ll post something here if I find anything that helps solve the issue.

If it actually is an issue, of course.

Mr Bailey

Online pnoboy

  • Mark I
  • ****
  • Posts: 321
    • View Profile
Re: Low volume and hiss on my MK 1 Stage
« Reply #8 on: February 09, 2018, 04:51:03 PM »
There's got to be something wrong.  The Rhodes puts out plenty of volume to make any guitar amp sound fine.  Can you borrow another amp from a friend to connect to your Rhodes?  If that test also shows a problem, then you definitely have to trouble shoot your piano.